Zur Boardunity Forenstartseite
  #1  
Alt 06.12.2005, 20:20
neues Mitglied
 
Registriert seit: 12.2005
Beiträge: 2

Problem mit wbb2(Version 2.3.3) forum


Ich betreibe ein wbb2 Klassen Forum der zugriff gerfolgt folglich über unsere Schule.
Mein Problem ist soweit sich einer aus meiner Klasse sich im Forum eingelogt hat.. und sich jetzt ein zweiter einlogt passiert es das der Zweite nach dem einlogen (mit seinem nick und seinem PW), aufeinmal denn Nick des ersten Users hat.. Könnte es daran liegen das sich mehre User über die gleiche IP einloggen..da sich die Schüler über die Schule einloggen?

Kann mir jemand helfen ich hab schon viel im ACP versucht einzustellen aber es klabt einfach nicht..
  #2  
Alt 07.12.2005, 21:35
Mitglied
 
Registriert seit: 01.2004
Beiträge: 173
Ich wüsste jetzt keine Erklärung für dein Problem,
aber an sich dürfte es da keine Probleme geben.

Ich habe hier selbst mehrere Rechner, und ein gleichzeitiges Anmelden mit den Rechnern und verschiedenen UserProfilen stellt kein Problem dar - auch wenn UserAgent und IP identisch sind.

Eine eindeutige Session wird über SessionID, IP und UserAgent (Browser) ermittelt.
Wenn ihr Cookies abgestellt habt, wird die SessionID an die URLs gehangen.
Bei aktivierten Cookies wird die SessionID aus dem entsprechenden Cookie verwendet und die URLs bleiben sauber.

In der Praxis läuft das so ab:
1. prüfen, ob eine SessionID über GPC (GET, POST, COOKIE) existiert
2. falls ja, dann wird mit der Session aus der DB gearbeitet (falls dort existent, ansonsten wird sie dort angelegt)
3. falls nein, dann wird eine SessionID generiert und in der DB abgelegt, zurück zu 1.

Ein Standardverfahren halt.

Dein Problem lässt sich aus meiner Sicht nur so erklären:

Die SessionIDs werden nicht weitergereicht.
Das kann passieren, wenn Cookies abgestellt sind und die IDs nicht in den URLs zur Verfügung stehen.
Achte mal darauf, ob bei abgeschaltenen Cookies 'sid=...' in den URLs vorkommt.
Sollte dem nicht so sein, ist entweder die acpl/lib/session.php oder die verwendeten Templates sind nicht standard (z.B. sollten in allen <a..> ein {$SID_ARG_1ST} oder {$SID_ARG_2ND}, seltener auch ein {$SID_ARG_2ND_UN} vorkommen).
Diese Variablen sorgen dafür, dass die SessionIDs in den URLs landen.

Sollte sich dein Board jedoch im Auslieferungszustand befinden, so weiß ich auch nicht weiter

cu

  #3  
Alt 21.12.2005, 18:05
neues Mitglied
 
Registriert seit: 12.2005
Beiträge: 2
Danke sehr ...

Antwort


Stichworte
-

Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.
Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Suche sehr gut besuchtes PC Modding Forúm tschekowski Projektvorstellung und Bewertung 3 28.03.2009 00:24
Stress im Chat - Chat ans Forum angliedern? Ann Community Management, Administration und Moderation 5 27.10.2005 20:49
Forenstruktur bei regionalem Forum summimasta Community Management, Administration und Moderation 0 24.10.2005 18:14
dotNetBB MrNase Forensoftware 9 02.06.2004 09:09
Gossamer Forum MrNase Forensoftware 4 17.04.2004 16:26






1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24