Zur Boardunity Forenstartseite
  #1  
Alt 04.03.2004, 17:56
Benutzerbild von exe
exe exe ist offline
titellos
 
Registriert seit: 07.2003
Ort: München
Beiträge: 888

MediaWiki - Probleme nach der Installation


Moin,

ich teste gerade das MediaWiki das auch in der Wikipedia zum Einsatz kommt. Die Installation ist gut verlaufen, allerdings habe ich danach zwei kleine Probleme.
Als erstes ist das Layout ziemlich krumm und schief, Teile überlappen sich, die Navigation ragt über den Contentbereich. Das ist allerdings eher ein kosmetisches Problem. Das andere ist das alle Links im Wiki auf http://localhost/wiki/... verweisen. Das Verzeichniss /wiki existiert aber nicht, ich habe die Software in /mwiki installiert. Die Pfade habe ich in der LocalSettings.php angepasst, ohne Erfolg.

PHP-Code:
$wgServer           "http://localhost";
$wgScriptPath       "/mwiki";
$wgArticlePath      "{$wgScript}?title=$1"
Hat das schonmal jemand eingerichtet und eine Idee woran das liegen könnte?
  #2  
Alt 04.03.2004, 18:26
Benutzerbild von Philipp Gérard
Zeitdenken
 
Registriert seit: 09.2003
Ort: Wien
Beiträge: 831
durchsuch einfach alle Dateien nach /wiki/ und ersetz es mit $wgScriptPath

__________________
Philipp Gérard
Gewöhnliche Menschen denken nur daran, wie sie ihre Zeit verbringen. Ein intelligenter Mensch versucht sie zu nützen. - Arthur Schopenhauer
  #3  
Alt 04.03.2004, 20:11
Benutzerbild von exe
exe exe ist offline
titellos
 
Registriert seit: 07.2003
Ort: München
Beiträge: 888
Der Pfad war zwar nicht hardcoded, dein Tip hat mich aber auf die richtige Spur gelenkt.
Das Wiki hat eine Standardkonfiguration die bei jedem Aufruf geladen wird. Die eigene Konfiguration hat aber die $wgScript Variable nicht korrekt neudefiniert. Lösung war folgende:

PHP-Code:
$wgServer           "http://localhost";
$wgScriptPath       "/mwiki";
$wgScript           "{$wgServer}{$wgScriptPath}/wiki.phtml";
$wgArticlePath      "{$wgScript}?title=$1"
Funktioniert einwandfrei, danke

Antwort


Stichworte
-

Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.
Gehe zu

Ähnliche Themen
Thema Autor Forum Antworten Letzter Beitrag
Problem mit Mediawiki mvorlaender Blog, CMS, Wiki und Sonstige 1 11.10.2004 14:27
Mediawiki : Problem bei der Integration Flightlevel Blog, CMS, Wiki und Sonstige 0 02.07.2004 21:27
Probleme mit WBB2 molly Forensoftware 2 18.02.2004 12:56
Probleme mit dem vBulletin 2.3.X Frederic Schneider Forensoftware 12 12.08.2003 21:41






1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24