Zur Boardunity Forenstartseite

Zurück   Boardunity Ratgeber Forum » Temporäre Foren » X-Mentor (Archiv)

 
 
LinkBack Themen-Optionen Thema bewerten
  #1  
Alt 23.08.2004, 16:48
neues Mitglied
 
Registriert seit: 08.2004
Beiträge: 4

Anfängerproblem: X-Mentor speichert nichts...


Hallo !

Nachdem meine mysql datenbank bei meinem provider schon nicht mitspielte und ich alle tables per hand konfigurieren musste läuft das Teil nun.

Einziges Problem: Egal ob ich eine Kategorie oder einen Artikel anlegen will, es wird nichts in mysql gespeichert. Ich bekomme zwar eine "Erfolgreich" Meldung doch es ist nichts da. Woran liegts?

Hoffe auf eure Hilfe,
Gruss Christian

Anmerkung: Ist es richtig das in der table "articles" der spaltenname "replace" auftaucht? Replace ist doch ein mySQL befehl und kann daher nicht als name für eine spalte benutzt werden. oder liege ich da falsch?
  #2  
Alt 23.08.2004, 17:05
Mitglied
 
Registriert seit: 10.2003
Ort: Bottrop
Beiträge: 779
Sorry, aber das hört sich für mich nach einem Problem mit deiner Datenbank an, ergo: Hoster kontaktieren.

__________________
Patrick Gotthardt
Patrick Gotthardt on Software
  #3  
Alt 23.08.2004, 17:09
neues Mitglied
 
Registriert seit: 08.2004
Beiträge: 4
ich habe jetzt alles noch einmal runtergeschmießen --> neuinstallation.

dabei habe ich festfestellt das x-mentor nicht einmal die tabellen installieren kann. siehe im anhang "error_log.txt".

woran kann das liegen, mein hoster ist strato.

bin für jede hilfe dankbar, denn ich will x-mentor.

gruss christian
Angehängte Dateien
Dateityp: txt sql_error.txt (2,1 KB, 461x aufgerufen)

  #4  
Alt 23.08.2004, 17:30
Mitglied
 
Registriert seit: 10.2003
Ort: Bottrop
Beiträge: 779
2 Möglichkeiten:
1. Archiv nochmal downloaden und neuinstallieren.
2. Hoster kontaktieren.

Kann's mir leider nicht erklären.

__________________
Patrick Gotthardt
Patrick Gotthardt on Software
  #5  
Alt 23.08.2004, 17:35
neues Mitglied
 
Registriert seit: 08.2004
Beiträge: 4
hi !

das hat nichts mit dem hoster zu tun, dort laufen die neusten php und sql versionen. ich denke vielmehr das x-mentor noch einige "kinderkrankheiten" hat.

Beim Versuch eine Kategorie anzulegen sagt die error_log:
[23.08.2004 - 18:31] Fehler #1064: You have an error in your SQL syntax near '`chef`,`name`,`link`,`visible`,`type`,`position`) VALUES ('0','12','','1','0','1' at line 1

Kann es vielleicht sein das die Hochstriche die DB nicht versteht?
Ich kann es mir nicht erklären, wäre schade wenn es nicht klappen würde.

Sonst noch Ratschläge? Hoster anrufen ist keine gute Idee. Wenn ich denen erkläre ich benutze x-mentor dann wissen die wahrscheinlich nicht wo das problem ist und verweisen mich auf die FAQ. Oder meinst du mein Hoster kennt jedes Stück php code das im web in umlauf ist?

Gruß Christian

  #6  
Alt 23.08.2004, 17:56
neues Mitglied
 
Registriert seit: 08.2004
Beiträge: 4
Scheint wohl doch noch ne Kinderkrankheit zu sein. Seit ich in der Inc/sql.class.php alle Hochkommas herausgenommen habe speichert x-mentor nun kategorien und artikel. auf der index seite erscheinen sie nicht und der bildupload geht leider auch nicht. es wird zwar ein bild hochgeladen allerdings wird es nicht angezeigt obwohl die dateigröße und typ stimmen.

komisch!

  #7  
Alt 23.08.2004, 17:59
Mitglied
 
Registriert seit: 10.2003
Ort: Bottrop
Beiträge: 779
Wenn die "`" einen mySQL-Fehler verursachen sollte kannst du mir nen Besen geben...
Das ist definitiv kein X-Mentor-Fehler. Der X-Mentor ist bereits auf einigen Server erfolgreich installiert worden und ich hab ihn auch schon problemlos installiert.
Daran kann es also nicht liegen.

d.h. es muss ein Problem mit deiner mySQL-Datenbank vorliegen, und da ist dein Hoster der einzige, der dir helfen kann.
Ich erwarte von denen nicht, dass die den X-Mentor kennen, aber die sollten in der Lage seien, dir zu erklären, warum solche Fehler zustande kommen.
Ich kann's mir nicht erklären.
Aber du könntest als Gegenbeispiel ein anderes auf PHP und mySQL basierendes Script installieren. Wenn das klappt kann ich dir beim besten willen nicht helfen.

__________________
Patrick Gotthardt
Patrick Gotthardt on Software
  #8  
Alt 23.08.2004, 18:16
Benutzerbild von komma
wbb2 Kiddy
 
Registriert seit: 08.2004
Beiträge: 31
Ich bin der Meinung das hier das Benutzerkonto von Seiten des zuständigen Administrator falsch eingerichtet wurde, daher würde ich mich den Vorrednern anschließen und meinen das eine Lösung nur vom Provider herbeizuführen wäre.

MySQL hat ein sehr ausgeklügeltes Rechtesystem und wenn die Rechtevergabe manuell vorgenommen wird, kann es durchaus schon mal im Eifer des Gefechts vorkommen, daß man einzelne Rechte versehentlich nicht vergeben hat.

Gruß komma.

  #9  
Alt 23.08.2004, 21:10
Benutzerbild von Philipp Gérard
Zeitdenken
 
Registriert seit: 09.2003
Ort: Wien
Beiträge: 831
Ein Fehler seitens des X-Mentors ist auszuschließen. Die Version 1.2.5 hat noch Kinderkrankheiten, SQL gehört aber nicht dazu. Hochkommas sind MySQL-Standart und Felder wie `replace` würden tatsächlich Probleme machen, wenn man sie nicht auszeichnet. Das bei Strato die neusten Versionen laufen mag ja sein, von ihrer Arbeit verstehen die Techniker dort trotzdem nicht.

__________________
Philipp Gérard
Gewöhnliche Menschen denken nur daran, wie sie ihre Zeit verbringen. Ein intelligenter Mensch versucht sie zu nützen. - Arthur Schopenhauer
  #10  
Alt 24.08.2004, 07:45
Mitglied
 
Registriert seit: 07.2004
Beiträge: 28
ich habe zur zeit 2 testversionen von xmentor auf einem strato server laufen.

beide ohne probleme. zumindest ihne sqlprobleme

rufe eben mal da an, bzw. schicke denen diesen thread hier...

 


Themen-Optionen
Thema bewerten
Thema bewerten:

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.
Gehe zu






1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24